We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Compatibility of Aspose.Cells with Visual studio 2015 and .NET framework 4.6

hello,
Support Team

we have multiple ASP.Net applications using Aspose.Cells version 8.1.0.2 and Aspose.Cells.Grid 7.0.0.2000 for .net framework 4.0.1 v

our company is moving to use .net framework 4.6 and Visual studio 2015

does Aspose version Aspose.Cells 8.1.0.2 and Aspose.Cells.Grid 7.0.0.2000 support framework 4.6 and VS 2015 ???

Hi,

Thanks for your posting and using Aspose.Cells.

Yes, they should work fine without any issue on Visual Studio 2015 and .NET Framework 4.6. In case, you find any error, please feel free to report it. We will investigate it and fix the issue. Thanks for your cooperation.

Hi we are trying upgrade ASPOSE.cells from Version 4.7.1.0 to 16.10.0.0 with VS 2015 and both .Net Framework 4.6 and 4.5. It’s throwing errors.



Errors as below:



1) Could not find Open method for Aspose.Cells.Workbook



2) Aspose.Cells.FileFormatType.Excel2003 method fails.



3) It does not support workbook.ConvertNumericData = false;



Please help us resolve the issues.

Hi Narender Patlolla,


Thanks for providing us details.

Well, for your information, we did reorganize the APIs structure and moved certain APIs to their corresponding namespaces since the release of v5.0.0. Over the years, we included many enhancements (regarding existing features) with other fixes and supported some new features. We have made the product more robust and feature rich APIs set now. You got to update your existing code (in accordance with latest APIs set) as we made some changes with existing APIs as well.

We recommend you to kindly see and browse Aspose.Cells for .NET Docs for your reference:
Also see the API Reference pages for your further reference:

For your issues:
1) The older Workbook.Open method is obsoleted/removed and you may use Workbook constructor instead now, see the sample code below for your reference:
e.g
Sample code:

//Instantiate the Workbook object and open an existing Excel file.
Workbook workbook = new Workbook(“e:\test2\Book1.xlsx”);

2) Please use FileFormatType.Excel97To2003 instead.

3) Please try instantiating and using TxtLoadOptions.ConvertNumericData attribute instead, see the sample code below:
e.g
Sample code:

TxtLoadOptions loadOptions = new TxtLoadOptions(LoadFormat.CSV);
loadOptions.ConvertNumericData = false;

Workbook workbook = new Workbook(“e:\test2\abc.csv”, loadOptions);

Hope, this helps a bit.

Thank you.

Thanks for the information.

I would like to work on code change and come back to you if I have any questions.



We also have an option to use our existing version ASPOSE.cells 4.7.1.0 with VS 2015.

Unfortunately it’s throwing error at run time.



Do you support VS 2015 (Frame work 4.5.2 or 4.6) with ASPOSE.cells 4.7.1.0 ?

In order to work with version 16.10.0.0 and VS 2015 (Frame work 4.5.2 or 4.6), Do I need to just replace the old version of Aspose.Cells.dll with Aspose.Cells.dll (16.10.0.0 version located under folder net4.0 ?

Hi Narender Patlolla,

narenderpatlolla:
In order to work with version 16.10.0.0 and VS 2015 (Frame work 4.5.2 or 4.6), Do I need to just replace the old version of Aspose.Cells.dll with Aspose.Cells.dll (16.10.0.0 version located under folder net4.0 ?

Yes, your understanding is correct.
Hi Narender Patlolla,

narenderpatlolla:
.... We also have an option to use our existing version ASPOSE.cells 4.7.1.0 with VS 2015. Unfortunately it's throwing error at run time.

Do you support VS 2015 (Frame work 4.5.2 or 4.6) with ASPOSE.cells 4.7.1.0 ?


Well, I am afraid, we cannot provide much help for your older version v4.7.1. Neither we can assure you that it would work fine on VS.NET 2015 (.NET framework version 4.5.x or 4.6.0). I think you may try to use Aspose.Cells.Dll library of your older version in the net2.0 folder (if it has - I am not entirely certain about it) @ your installation directory if it works fine.

Thank you.

Amjad,



Thanks for the information.

I fixed all the old methods and replaced with new methods in my code. I could able to compile the application without errors. Now we decided to use your ASPOSE Version 16.10.0.0. with Visual Studio 2015 and Frame work 4.5.2. But When I tested to create Excel and PDF files it’s throwing licensing error. I believe we need license to use ASPOSE Version 16.10.0.0. Please confirm.





I could not find in your documentation saying that ASPOSE Version 16.10.0.0 supports VS 2015. If you have any online documentation information, Please let me know.

Hi Narender Patlolla,


Yes, you need to upgrade your subscription to use latest versions of the Aspose.Cells APIs.
And, yes, Aspose.Cells for .NET (v16.10.0) does support VS.NET 2015 (.NET framework versions v4.5.x, 4.6, etc.), see the document for your reference:
http://www.aspose.com/docs/display/cellsnet/System+Requirements

Thank you.

Hi Amjad Sahi,



Thanks for your prompt reply.



We bought license for ASPOSE CELLS 16.11.0.0

Downloaded this version of DLL and copied both DLL and new License file to the application bin folder and removed the old dll and old license files. Modified the code as per the new dll and successfully compiled. I am using VS 2015. When I run the application I could see following error in my event log.



“System.InvalidOperationException: The subscription included in this license allows free upgrades until 29 May 2010, but this version of the product was released on 09 Nov 2016. Please renew the subscription or use a previous version of the product.”



Please suggest

Hi,


As per the exception, it looks like your application is still using older license, so please make sure your application should use newer license file with our latest Aspose.Cells for .NET v16.11.x. I think you should debug your code segment (regarding license) by yourself where it is placed and it is processed fine and look for the newer license file on the specified filepath/streams etc, you may put break points at the specified lines of code. You may also evaluate if the newer license file is working with latest version of the product, you can create a separate console application and put the licensing code at the start to check if the license works fine with latest versions, it should work fine.

In case you still think there is some issue with licensing module, please post your license file using the instruction given in the document:
http://www.aspose.com/corporate/purchase/faqs/send-license-to-aspose-staff.aspx

Thank you.

HI Amjad Sahi,

Thanks for the reply. I could able to resolve the issue by copying the new dll and new license file to all the related projects.

Now I have another issue as described below.

We are using a open method of the workbook.

workbook.Open(combinedStream, Aspose.Cells.FileFormatType.CSV);

The above code throwing an error as shown below.

CS1061
‘Workbook’ does not contain a definition for ‘Open’ and no extension method ‘Open’
accepting a first argument of type ‘Workbook’ could be found (are you missing a using directive or an assembly reference?

I am using ASPOSE CELLS 16.11.0.0 version with VS 2015 with .Net Framework 4.5.2.

I understand that new version does not support the Open method. please suggest the correct method to use.

Thanks
Narender

Hi,


Good to know that your issue is sorted out now. For your Workbook.Open() method issue, please use Workbook constructor instead for opening Excel files when using the newer APIs set. We recommend you to see the documents for your reference:
http://www.aspose.com/docs/display/cellsnet/Opening+Files+with+Different+Formats
http://www.aspose.com/docs/display/cellsnet/Opening+Different+Microsoft+Excel+Versions+Files

Thank you.

Thanks Amjad Sahi!



Subject: Aspose.Cells 16.11.0.0. version compatibility with Visual Studio 2015 and .Net Framework 4.5



As per your suggestion, I could able to resolve the issues I raised in my previous posting.



Now I am facing few other issues.



1) The last few lines, ranging from 1 to 4 lines, of the text in the PDF reports page is printing on the next page. These last lines show the total amount for the data on page.



2) When the data is exported to CSV file with a word including apostrophe Example “institution’s” showing is as “institution’s”



Please check the attachment and suggest me the appropriate action.

Hi,


Thanks for the word document for the details about your issue(s).

Good to know that your previous issues are sorted out now.

1) Could you open your template file into MS Excel and take the print preview of sheet, you should see similar display (last few lines are rendering on the next page). If not, kindly do provide us your template Excel/CSV file and sample code that you are using with newer version/fix (e.g v16.12.x) of the product, we will check it soon. Also attach your output PDF file here.

2) Please provide us a simple sample project (runnable) using our latest version/fix with your template files to reproduce the issue on our end, we will check it soon.

PS. Please try our latest version/fix: Aspose.Cells for .NET v16.12.4:

Aspose.Cells for .NET v16.12.4 (.NET 2.0)
Aspose.Cells for .NET v16.12.4 (.NET 4.0)

(Note: please download any of the versions for your underlying .NET Framework version)

Thank you.

Hi Amjad Sahi,



I could able to fix the issue 1 that is related to PDF report but issue 2 ( CSV file) still persist.



Here is the information as below:





When we add the word “institution’s” to the Excel report (CSV file output) it’s displaying on CSV file as “institution’s”. Basically it’s replacing

“’” with “’” internally in the ASPOSE.CELLS DLL.



Following line is the code we are using:



worksheet.Cells[0, 0].PutValue(“institution’s”);





Note:



1) Here worksheet is Aspose.Cells.Worksheet object



2) We are using latest ASPOSE.CELLS version: Aspose.Cells for .NET v16.12.4.0



3) We are using Visual studio 2015 and .Net Framework 4.5.2



Please let me know the fix details for this issue

Hi,


Good to know that you have sorted out your first issue.

Regarding issue 2, well, I have tested your scenario/ case in a simple console application with our latest version/fix: Aspose.Cells for .NET v16.12.5, it works fine and I could not find the issue in the output CSV file, see the screenshot for your reference:
http://prntscr.com/drhdfs

I have also attached the VS.NET 2015 demo project for your reference here. The output CSV file is in the “bin\Debug” folder with the library (v16.12.5). Could you please try to execute the sample project (attached) and find the output CSV file to check if you find any issue with it.

Thank you.

Hi Amjad,



I could able to resolve the csv file special character issue by replacing ’ (single quote) with ’







However while publishing the application, I am receiving compiling error in release mode for the Aspose.Cell.dll





I am not receiving any error in debug mode while compiling but could see following error while compiling in release mode.





Error:



Error: Could not load file or assembly ‘file:///…\bin\Aspose.Cells.dll’ or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515) C:…\Source\SGEN







Note: I tried switching to use local dll instead of

shared and also set the referenced aspose.cell.dll

copy local property to “true”. It did not help.









Please suggest

Hi,


Please make sure that you are using Aspose.Cells.Dll assembly compiled on .NET Framework version 2.0 or 4.0.

This does not look like an issue with Aspose.Cells APIs. Your issue might occur due to Aspose.Cells being blocked on your system/environment. Please see and browse the following documents/ threads for your reference:
http://stackoverflow.com/questions/8524423/could-not-load-file-or-assembly-hresult-0x80131515-when-adding-controller-to-m
http://www.chilkatforum.com/questions/8260/could-not-load-assembly-operation-not-supported-exception-from-hresult-0x80131515
https://blogs.msdn.microsoft.com/brada/2009/12/11/visual-studio-project-sample-loading-error-assembly-could-not-be-loaded-and-will-be-ignored-could-not-load-file-or-assembly-or-one-of-its-dependencies-operation-is-not-supported-exception-from/

If you still have any issue, kindly create a separate sample project (runnable) with latest Aspose.Cells for .NET version, zip it and post us here to show the issue, we will check it soon.

Thank you.