We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Convert DOC to PDF and Sign it using Aspose.PDF for .NET - Adobe is not accepting the signatures

Whenever I add a simple form field to an Aspose PDF file (created from a Word doc), Adobe Sign refuses to send it out for signature and returns “Adobe Sign was unable to create your agreement because the document could not be thumbnailed.” (adobe reports that this is a general error message to say that something went wrong).

Our documents without fields go through fine, but as soon as I add a checkbox field, Adobe Sign rejects the PDF (I tried swapping between the docs to confirm that Adobe Sign’s service wasn’t down). The PDF loads fine in all browsers/PDF readers and the added field is editable.

I’m using Aspose 19.5. I’ve run out of ideas and haven’t found any relevant info here or on the net.

Here’s the code to add the field:

byte[] workingPDF = /* valid PDF buffer */;

            using (MemoryStream memStream = new MemoryStream(workingPDF))
                Document doc = new Document(memStream);

                FormEditor form = new FormEditor();

                form.AddField(FieldType.CheckBox, "bool1", 1, 200.0f, 600.0f, 245.0f, 630.0f);

                // create a new stream just to be sure
                using (MemoryStream savedStream = new MemoryStream())

                    // From this point on, Adobe Sign will return "Adobe Sign was unable to create your agreement because the document could not be thumbnailed."
                    workingPDF = savedStream.GetBuffer();

I also tried setting the privilege levels as per this forum post, but that didn’t fix it.

Thanks for any help!


Thank you for contacting support.

We have attached the PDF document generated with the code snippet shared above. Would you please elaborate further steps for reproducing the issue and specify if you are trying to sign it with Adobe Acrobat or not. We will then proceed to help you out. AdobeSign_19.5.pdf

Thank you for providing a sample. That one goes through Adobe Sign fine, even after I run the above code to add a second field to it.

Yet, if I create a similar Word doc, convert it to PDF with Aspose, save it, load it, add a field using the above code, it doesn’t go through Adobe Sign.

I’ve attached a sample here that’s similar to yours (which Adobe Sign rejects). I’m hoping you have a way to view the underlying content to see what the difference is… I noticed our file sizes are very different, but browsing the Aspose.PDF objects doesn’t reveal much in terms of differences.

To answer your question, the problem occurs when we upload the PDF to Adobe Sign’s website in order to have other people sign it. Adobe Sign refuses to even send the PDF to signing parties because there’s something about it that it doesn’t like.

Here’s a simple PDF that Adobe Sign rejects:

MyTestAfter.pdf (32 KB)


Thank you for elaborating it further.

We are checking this and will get back to you with our findings soon.


How did you produce ‘MyTestAfter.pdf’? We are even not able to view the content of this file when opening with Adobe Acrobat DC. Have you tried the latest version of Aspose.Words for .NET i.e. 19.6? In case the problem still remains, please ZIP and attach the following resources here for testing:

  • Your simplified input Word document
  • Aspose.Words 19.6 generated output PDF document
  • Aspose.PDF 19.6 generated final PDF document
  • Please also create a simplified standalone console application (source code without compilation errors) that helps us to reproduce your current problem on our end and attach it here for testing. Please do not include Aspose DLL files in it to reduce the file size.

As soon as you get these pieces of information ready, we will start further investigation into your issue and provide you more information. Thanks for your cooperation.