We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Diagram: Datarow values changing

Hi,

in the Excel file “Input” attached, there is a diagram on sheet “Ausschuss”. Editing the datarow of datasource “Mai” shows the row value “=Input.xlsx!Mai” (see screenshot “before”).
After opening the file with Aspose.Cells and changing/adding some data on sheet “Dummy” and saving the file under a new file name (“Output”), the row value has changed to the incorrect value “=Ausschuss!$MAI$0”.
The row values of the other two datasources “April” and “Maia” are changed to the correct new value, only “Mai” went wrong.

I think the problem has something to do with using the German Version…
Currently we are using version 5.3.1.7 of Aspose.Cells.

Sincerely,
Matthias Wohlmann

Hi,

Thanks for your reporting and your interest in Aspose.Cells for .NET.

Kindly test the issue with the latest version: Aspose.Cells
for .NET v6.0.1.1


If the problem persists, then provide us your code example. We will look into this issue and update you asap.

Hi,

I have tried the latest version - same result.
I think, sample code is not neccesary: We are just opening the input file, changing data in sheet “Dummy” without touching anything in the other sheets, and then saving the excel file under a new name.

Also see thread
<span style=“font-size:12.0pt;font-family:“Times New Roman”,“serif”;
mso-fareast-font-family:“Times New Roman”;mso-ansi-language:DE;mso-fareast-language:
DE;mso-bidi-language:AR-SA”><a href="
where I had a similar problem that was solved by Aspose.

sincerely,
Matthias Wohlmann

Hi,

Thanks for clarification. I was able to reproduce this bug using the following with latest version: Aspose.Cells
for .NET v6.0.1.1


I have attached the screenshot for a reference.

This issue has been logged as CELLSNET-29413.

C#


string path = @“F:\Shak-Data-RW\Downloads\Input.xlsx”;


Workbook workbook = new Workbook(path);

workbook.Save(path + “.out.xlsx”);

Screenshot:

Hi,


Please try the attached fixed version, your issue should be fixed now.

thank you.

Hi,

yes, that fixed the problem.

Thank you very much!
matthias

The issues you have found earlier (filed as 29413) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan