We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error: The current configuration system does not support user-scoped settings

Hi, I just upgraded the Aspose.Email.dll from 5.0.0 to 5.7.0 and when I try to send an email from my web application I receive the error “The current configuration system does not support user-scoped settings”. No other changes have been made to the code and if I revert back to 5.0.0 it works fine.


I note this problem was raised with a previous upgrade here:

Error with 2.2.0.0 The current configuration system does not support user-scoped settings

I wonder if the same problem has been reintroduced??

This is the line that raises the exception…


client = EWSClient.GetEWSClient(serverName, userName, password)

I also tried version 5.6.0 and received the same error.

I haven’t tried 5.1 through 5.5, but I do know that 5.0.0 works (i.e. it does NOT raise the exception).

Hi David,

Thank you for posting your inquiry.

We have tested this issue with the latest version of the API and it works with both Exchange Server 2010 and online Office 365 account. You can test it with the following test account. Can you please check it with this test account and share your feedback?

dynamic client = EWSClient.GetEWSClient("https://outlook.office365.com/ews/exchange.asmx", "UserOne@ase1985.onmicrosoft.com", "Aspose1234");


Yes it works fine in a windows forms or console application, but NOT in a web application. Something in your code is apparently trying to access a setting with user scope which is not valid for a web application. I found details in the following articles:

http://stackoverflow.com/questions/2049035/the-current-configuration-system-does-not-support-user-scoped-settings

[http://stackoverflow.com/questions/14964315/asp-net-current-configuration-system-does-not-support-user-scoped-settings-error ](http://stackoverflow.com/questions/14964315/asp-net-current-configuration-system-does-not-support-user-scoped-settings-error)

Hi David,


I have re-produced the issue here and logged it under id: EMAILNET-34977 for further investigation by the product team. I shall write here as soon as some feedback is received in this regard.

Hello,

I am also experiencing this issue and only when I use the dll in a web app. Can you provide a date as to when this will be resolved? We need this dll corrected ASAP. Thanks.

Regards,
Mike

Hi Mike,

The issue has been fixed by now and will be part of our next release that will be available in the first week of Oct 2015. We’ll notify you here once the fix version is available for download.

I’m getting the same error in both v5.7 and v5.6. Had to roll-back to v5.5


Would be great if you would release such hotfixes out of your normal release cycle.

/Morten

Hi Morten,


This issue is resolved in our upcoming release Aspose.Email for .NET 5.8.0. You may please wait for a few days, as this version is ready for release and is under QA testing. You will be automatically notified once the new version is released and available online for download.

The issues you have found earlier (filed as EMAILNET-34977) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(1)