We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Excel export merge row cells error

Hi,

In some cases we found out a strange behavior I cannot explain to my customer : one row data is merged into two rows data in Excel.

This doesn’t happen when exporting to Excel without using ASPOSE component as you can see in the attachment picture.

On the left side this is when we attempt to export as a XLSX Aspose file and on the right side it's the same report using classic Excel format.


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

<![endif]–>

Hi,


Which product you are using, do you use Aspose.Cells for Reporting Services? If so, please provide us sample RDL file and exported XLSX and XLS files here. We will check it soon.


If you are using Aspose.Cells for .NET/JAVA, please give us sample code or console application to reproduce the issue on our end. Also, attach the template and output files.

Thank you.

Thank you Amjad,

We are using Aspose.cells for reporting Services. Please find the files you’ve requested:

  • Interface_BO_Infra(1).xls : classic Excel export
  • Interface_BO_Infra.xlsx : Aspose XLSX export
  • Interface BO Infra.rdl : SSRS report

Hi,

Thanks for providing us details and template files.


We will look into your issue soon.

By the way, could you please download and try the latest fix/version in which we made a few enhancements regarding XLSX rendering: Aspose.Cells for Reporting Services V1.8.0.64(SSRS2008).

Please copy Aspose.Cells.ReportingServices.dll into following folder:

${SQL Server 2008 Reporting Services}\Reporting Services\ReportServer\bin.

Please let us know your feedback if it works fine. We will surely log a ticket for your issue.

Thank you.

The rendering is different, but the problem still occur as you can see in the picture.

Hi,


Thanks for your feedback and using the latest fix.

We have logged a ticket with an id: SSRS-40067 for your issue. We will soon look into it to figure it out soon.

Also, check the document for your reference:
http://www.aspose.com/docs/display/cellsreportingservices/Performance+Configuration
By the way, could you check the "Aspose.Cells.ReportingServices.xml" file. You may specify the merging parameters / values accordingly in the "Aspose.Cells.ReportingServices.xml" file if it makes any difference.

Thank you.

Hi,

We have found these issues and fixed them.

Please download and try the fixed version: Aspose.Cells for Reporting Services V1.8.0.65(SSRS2008).

Please copy Aspose.Cells.ReportingServices.dll into following folder:

${SQL Server 2008 Reporting Services}\Reporting Services\ReportServer\bin.

Please let us know your feedback.

Your collegue Amjad Sahi has already mentionned that but it didn’t worked after I installed the DLL on the location provided… I’ve got the same result.

DidierEsteves:
Your collegue Amjad Sahi has already mentionned that but it didn't worked after I installed the DLL on the location provided... I've got the same result.

Hi,

No, it is actually a new dll which we have provided you after fixing your issue. The earlier dll number given by Amjad was 64 but this is 65.

Please give it a try and let us know your feedback.

Attachment: ACRS2008.V1.8.0.65.zip

Thanks for this quick answer, I’ll try this out.

If it works : where do I can find the MSI with this version? Actually this version is not available for download, am I right?

Hi,


Well, the new fix v1.8.0.65 should work fine for your requirements.

Also, this fix is although an intermediate release or is a kind of hotfix, you may surely use this fix for your production usage. Normally a bug fixed version is posted in the support forums for the users (in the form of Dll format) that includes all the functionality of the product with its previous releases/fixes. However we will see if we can provide you an MSI installer for it. Also, we are scheduled to release our next official release of the product (that will be published in the Downloads module of the site) which is due in November 2012.

Thank you.

Hi,

I confirm that this version is functioning : I’ve got the rows that I want with no merged rows.

Just one more question : why do I have no values when I export to other formats while the XLSX format I’ve got all the data??

Hi,


Which file formats you are exporting to? Could you attach us some exported files in other formats. We will check it soon.

Thank you.

Hi,

Thanks for your feedback.

It’s good to know that your issue is resolved with the latest fix.

Let us know which other formats are not working.

In case of CSV format, then it is a text based format, it might not support the Xls/Xlsx renderings like Styles, Merging of Rows/Columns etc.


It’s for example with the “XLSX Data only” format. You can find a sample in the specified document.

DidierEsteves:
It's for example with the "XLSX Data only" format. You can find a sample in the specified document.
Hi,

Thanks for your clarification and providing us the output file.

We have logged this issue in our database. We will look into this issue and resolve it. Once the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as SSRS-40069.

Hi,

We have found the issues and fixed them.

Please try the fixed version: Aspose.Cells for Reporting Services V1.8.0.67 (SSRS2008).

Please copy Aspose.Cells.ReportingServices.dll into following folder:

${SQL Server 2008 Reporting Services}\Reporting Services\ReportServer\bin.

Let us know your feedback.

The issues you have found earlier (filed as SSRS-40069;SSRS-40067) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.