Free Support Forum - aspose.com

File is opened in Protected View after conversion to XLS

Scenario: Simply set password to open and convert attached sample file to XLS format. Aspose.Cells 8.7.0.0.


Issue: File is opened in Protected View.

If I do not set Password to open, then protected view is not used.

var w = new Workbook(@“d:\sample.xlsm”);
w.Settings.Password = “1”;
w.Save(@“d:\sample.xls”);

Thanks,
Alex Shloma

Hi,


Thanks for providing us template file and sample code.

After an initial test, I observed the issue as you mentioned by using your sample code with your template file. I found that the output file is opened in Protected View in MS Excel. Performing the same operation manually in MS Excel does not produce such behavior.
e.g
Sample code:

var w = new Workbook(@“d:\sample.xlsm”);
w.Settings.Password = “1”;
w.Save(@“d:\sample.xls”);

I have logged a ticket with an id “CELLSNET-44195” for your issue. We will look into it soon.

Once we have any update on it, we will let you know here.

Thank you.

Hi,

Thanks for using Aspose.Cells.

This is to inform you that we have fixed your issue CELLSNET-44195 now. We will soon provide the fix after performing QA and including other enhancements and fixes.

Hi,

Thanks for your using Aspose.Cells.

Please download and try the latest fix: Aspose.Cells for .NET v8.7.0.2 and let us know your feedback.

Hi,


Tested on my side. My sample files are no longer opened in Protected View.

Thanks.

Hi,

Thanks for your feedback and using Aspose.Cells.

It is good to know that your issue is resolved with the latest version. Let us know if you encounter any other issue, we will be glad to look into it and help you further.

The issues you have found earlier (filed as CELLSNET-44195) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

A post was split to a new topic: View changed to protected while converting XLS->XLSM->XLS