Free Support Forum - aspose.com

Font loading and Rendering issues in Linux Docker with Net Core 2.2

Hi Aspose. I’m building a web application using your library and i faced some issues. First of all i’m using .Net core version 2.2 inside linux Docker container. First issue is related to the fonts: i can’t make my application use correct fonts. I already added fonts in the local directory and added reference to it with FontsLoader.LoadExternalFonts() and this doesn’t help.
Second issue is related to the fact, that in some cases when i’m trying to get thumbnail of an arrow, the result thumbnail doesn’t contains an arrow. This is a known issue and it was resolved here but this issue still reproduced win .net core in linux.
The third issue is that in some cases background color of shapes differs from the original one in the Powerpoint. You can see the difference here and lines in thumbnails have slightly more width and are not rounded.
And the last issue is related to the fact, that Linux doesn’t support .wmf/.emf files. So if presentation contains embedded .emf/.wmf files i can’t get their thumbnail.

@obrusentsov,

I have observed your issues and requirements.

I have observed your requirement and we need to have source project and source file along with used fonts that are not getting loaded.

I request you to please share the source file, sample project and output achieved on your end.

I request you to please share the source file, sample project and output achieved on your end.

Your observation is right in this regard.

I also suggest you to please first try using latest Aspose.Slides for .NET 19.10 on your end so that we may proceed further with investigation on our end.

Thank you for your fast reply. Here is a link to a source code of a sample with a bad font. And here you can see how Powerpoint is rendering it

Here is a second code sample with a presentation, containing an arrow shape. Here is a picture of what aspose produces.

Here is a third code sample with with wrong shape fill color. And here is a conversion result

@obrusentsov,

We are working on your issue and will get back to you with feedback soon.

1 Like

Hi guys. Is there any information concerning .Net core available?

@obrusentsov,

I have worked with source files shared by you using Aspose.Slides for .NET 19.10 and unable to observe issue. I like to inform that i have tested this on window 10 environment. Can you please share complete environment details with us. For reference i have attached my generated result with you.slide1.png (44.5 KB)

That’s odd. I also use Windows 10 build 1809 and Linux Docker container

Do you also use docker and linux container?

And could please you provide some information about the rest of issues?

@obrusentsov,

I have observed your comments and created following ticket for further investigation to help you out.

  • Font Issue :SLIDESNET-41519

  • Shape Issue:SLIDESNET-41520

  • Fill Color Issue:SLIDESNET-41521

We will notify you once issues will be resolved. I request for your patience.

Thank you, looking forward for the results

@obrusentsov,

Sure, we will share updates as soon as it will be fixed and request for your patience.

Any update here? Waiting for confirmation of a fix

@markbeare,

I like to inform that these issue has been added recently in our issue tracking system. As per company policy issue are resolved on first come first serve basis and priority are given first to paid support support customer than free support customer issues are resolved. We will share good news with you soon.

The issues you have found earlier (filed as SLIDESNET-41520) have been fixed in this update.

@obrusentsov,

We have investigated following issue on our end.

We have not been able to reproduce the issue and it seems that there is all fine from our side.
Can you please check for Helvetica Neue font by installing it on Win10 (It is not present in system by default).

On the PowerPoint’s view with the source presentation from you:

(https://drive.google.com/file/d/1Jy-QQ2PLEB4Ugb84U6GCcZM3KG6lT-Ur/view)

We have not sees Helvetica on first line. This is a Cambria Math - substitution font.

The examples are attached for your reference.

HelveticaNeue.png (3.9 KB)
CambriaMath.png (4.5 KB)

The issues you have found earlier (filed as SLIDESNET-41521) have been fixed in this update.