For a particular file ,In tabular column 2rows datas are missing

for a particular file ,In tabular column 2rows datas are missing

while using online convert also … this is showing like this
Screenshot_889.png (144.0 KB)

Can you write in more detail what you would like to do and attach the source file.

s … the original file is
FLUTISALM_AS_18_B FPM 1_cropped.pdf (481.5 KB)

In page 2 : exactly 49 and 50 rows in tabular column is incorrectly displaying
in page 3 : exactly 109 and 110 rows in tabular column is incorrectly displaying
like wise this is repeating for the entire document

Particularly this happens in pdf to csv conversion (converting through code in java)
will show how it looks in my web application

Screenshot_891.png (149.5 KB)

Screenshot_890.png (148.5 KB)

on converting this in aspose online converter
1st attempt : single page alone is converted
2nd attempt : the above specific screenshot happens

for any more clarification pls ping

I tried to reproduce the problem in Windows. Used a project for .Net 6, library version 23.10 and code

var pdfDocument = new Aspose.Pdf.Document(dataDir + "FLUTISALM_AS_18_B FPM 1_cropped.pdf");
var saveOptions = new Aspose.Pdf.SvgSaveOptions();
// saveOptions.CompressOutputToZipArchive = false;
string outputFileName = dataDir + "Tables-out.svg";
pdfDocument.Save(outputFileName, saveOptions);

image.png (74.1 KB) (1.4 MB)

I did not see any violations.
What version of the library are you using?
Or maybe I overlooked/did something wrong.

I am using java 8 , SpringBoot version : 1.4.2.RELEASE
our application is java based web application .

i am using pdf to csv conversion ,

String convertedcsvfilePath = “uploads/”+ name + “.csv”;
License asposePdfLicenseCSV = new License();
try {
asposePdfLicenseCSV.setLicense(“License path”);
} catch (Exception e) {
Document convertPDFDocumentToCSV = new Document(“uploads/” + fileName);
ExcelSaveOptions csvSave = new ExcelSaveOptions(); csvSave.setFormat(ExcelSaveOptions.ExcelFormat.CSV);, csvSave);

this is how , v r converting a pdf to csv file

I apologize for my carelessness.
I checked the code provided and the error was not reproduced.
Then I tried the code with the library version 23.2 and the error was reproduced.
Try the latest version of the library: 23.9.

ok , will check and update

I have checked , After updating the Aspose version from 22.12 to 23.9
this issue got resolved.
Screenshot_895.png (173.3 KB)

@sergei.shibanov Thank you for the Assistance provided.

Glad you got it resolved, thanks for the feedback.

Hi ,
Recently , I have came across a new file , with data loss issue , the configurations are same as specified for the older issue ,

The file i am using is :
575 (8.1 KB)

In that file data loss is ,
in samplename column i am getting amplename


Can you please share the sample PDF document that you are converting into CSV? We will test the scenario in our environment and address it accordingly.

I have attached above , that ZIP contains , csv file which shows data loss


The ZIP only contains CVS. We believe that you obtained this CSV after conversion from PDF? Right? We need sample PDF that you converted into CSV. Please also share the screenshot of the data loss so that we can better understand the issue and address accordingly.

OK will ask my customer to send pdf of this csv
sry for the delayed reply


Please take your time to gather the sample file and feel free to share with us. We will test the scenario in our environment and address it accordingly.

Hi ,
I have collected a sample file , while doing pdf to csv conversion i am getting a line extra ,
Screenshot_11.png (174.5 KB)

i will upload original file too
ASSAY API (Single Content) _5 (1).pdf (10.1 KB)


We were not able to reproduce the issue in our environment:

Document doc = new Document(dataDir + "ASSAY API (Single Content) _5 (1).pdf");
ExcelSaveOptions options = new ExcelSaveOptions();

ASSAY API (Single Content) _5 (1).zip (785 Bytes)

Also, it looks like you are not setting the license before using the conversion code which is why you are getting evaluation message in the output CSV. Please make sure that you set a valid license and in case issue still persists, please let us know.

ok will check in myside and update u regarding.
Thanks for immediate Respose

I am getting this error
Screenshot_17.png (146.3 KB)
this is how i am setting license
Screenshot_18.png (143.9 KB)

I am using classpath of the license
pls help me with this


Its a generic error that typically occurs when provided XML file is corrupted or badly formatted. Please make sure that license file is fine by accessing it using full file path. You can then try InputStream inputStream = getClass().getResourceAsStream("/path/to/your/license.lic"); method to verify if it works. Please let us know in case you still face any issues while testing the license file with full path.