Free Support Forum - aspose.com

Getting message "At most 4 elements (for any collection) can be viewed in evaluation mode." but my license is still good till next year

Hello. I am receiving the following message out of nowhere starting today. “At most 4 elements (for any collection) can be viewed in evaluation mode.”

The software has been working fine for months, and just now it says this. My license file says the expiration date is 20160114, so it should not be trying to use evaluation mode. I am using Aspose.Pdf version 1.5 and have always been using it from the start.

What could have happened to cause this?

Hi John,


Thanks for your inquiry. We will appreciate it if you please share your license file via email as suggested here. So we will look into it and will provide you information accordingly.

Best Regards,

When I saw that error message, I only experienced it in the new build of the app, and did not have the problem on another device that was running code in production. So, I ended up re-building the app and re-installed it on my device that has the development code, and it worked that time. Is it possible that maybe the license file somehow didn’t get included in the previous installation of the build? I have it stored as a raw resource in the project.

Hi John,


During our testing, we did not encounter such issue but there can be chances that license is not included during application compilation. Please continue using our API and in case you still encounter the same issue, please feel free to contact. Once again, we are sorry for this inconvenience.

I received the same error again the other day with no ideas to explain why it wasn’t working. It worked the previous day, and not the next, but today it is working again. I have been running the same version of my app during the entire time. Why would it pick and choose days to stop working?

Hi John,


Please ensure that you do not have multiple copies of license file over same location (a temporary expired license and valid license) or there is some service installed over your system which is preventing access to license which your Android application tries to load.

In case you do not find any specific reason for license unavailability to application, as requested earlier, please share the license file, so that we can test the scenario in our environment. In order to share the license, please follow the instructions specified over How to send a license?

We are really sorry for this inconvenience.