We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

GridWeb.SaveToExcelFile not including entered data

I have a GridWeb that is pre-loaded with some data. AJAX is enabled so that calculations are performed in real time. I have implemented the SaveCommand exactly as shown in the demos and numerous posts here on the forum and it creates an Excel file that is formatted exactly as the GridWeb.


If I enter some values into the grid and then click the Save image to create the Excel spreadsheet, it does not contain these newly entered values. It only contains the initial values. I would like it to contain all values that are currently in the grid.

Is there some method I need to execute before SaveToExcelFile so that all of the values I have entered are included in the Excel file that is created? I have attached my .aspx and .aspx.cs files for your review.

Thank you very much for your continued help.

Hi,

Thanks for reporting the problem and using Aspose.

I was able to replicate the problem using the latest: Aspose.Cells
for GridWeb v2.7.2.2002



We have logged this issue in our database. Development team will look into it and fix the problem and we will let you know asap.

This issue has been logged as CELLSNET-40313.

It has been 2 weeks. Is there any progress on this issue?

Hi,

I am afraid, your issue is still unresolved.

Will you please also try the latest version:
Aspose.Cells
for GridWeb v2.7.2.2003

and let me know your feedback.

I have also added your comment in our database. As soon as we will get some update relating to it or some fix, we will let you know.

Hi,

We have fixed this issue. Please download and try the latest version: Aspose.Cells for GridWeb v2.7.2.2004

The attached version works as expected. Thank you very much for your help.

The issues you have found earlier (filed as CELLSNET-40313) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Has this issue been really resolved, I am still facing the same kind of problem, can you please check into this?

Thanks

Jaisree

Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

Yes this issue has been fixed. Please download and try the latest version: Aspose.Cells for .NET 8.5.1 and it should fix your issue.

If your issue still occurs with the latest version then please provide us your sample website project replicating the issue with the latest version. We will look into it and update you asap.