Free Support Forum - aspose.com

Image Created differing from PC to PC

Hi Aspose,

I have used the following code to generate image from a excel file.
Workbook book = new Workbook(“D:\workbook.xls”);
Aspose.Cells.Worksheet sheet = book.Worksheets[0];
ImageOrPrintOptions options = new ImageOrPrintOptions();
options.IsImageFitToPage = true;
options.OnePagePerSheet = true;
options.TiffCompression = TiffCompression.CompressionLZW;
options.ImageFormat = ImageFormat.Emf;
options.PrintingPage = PrintingPageType.Default;
SheetRender sr = new SheetRender(sheet, options);
sr.ToImage(0, “D:\Image.emf”);

I have used this code on 2 different machines:
one with xp os and the other one with windows server 2008 and the images generated are different also the font size is considerably different with the actual font size in the excel file.
Please find the attached images.
Thanks and Regards
Mukund

Hi,


I am not able to see your both screen shots you attached, could you re-attach them here again.
Also, kindly give us your sample file that you are using. Also do you find the issue (different images) with any file’s output image on both PCs?

By the way, kindly make sure that you have installed all your required fonts on the machines that are used in the Excel file.

Thank you.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We were able to see the images and their differences, however, in order to investigate this issue further, we need your source workbook.xls (as used in your code).

Please also download and try the latest version: Aspose.Cells
for .NET v7.3.4.2
to see if it makes any difference at your end.

Please see the following screenshot for your reference. We will look into your issue and help you asap.

Screenshot:

Thanks for the reply Shakeel Faiz.

I have used the dll provided by you and the issue still exists.
I’m attaching the excel sheet that is getting generated in both the machines for the image generation.
You can see the font size in Excel file and the font size in Images are all different.
Thanks and Regards
Mukundan

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We were able to replicate this issue using the latest version: Aspose.Cells
for .NET v7.3.5.1


We have logged this issue in our database. We will look into this issue and fix it. Once the issue is fixed or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41309.

C#


string filePath = @“F:\Shak-Data-RW\Downloads\ExcelInWin7.xls”;


Workbook book = new Workbook(filePath);

Aspose.Cells.Worksheet sheet = book.Worksheets[0];

ImageOrPrintOptions options = new ImageOrPrintOptions();

options.IsImageFitToPage = true;

options.OnePagePerSheet = true;

options.TiffCompression = TiffCompression.CompressionLZW;

options.ImageFormat = ImageFormat.Emf;

options.PrintingPage = PrintingPageType.Default;

SheetRender sr = new SheetRender(sheet, options);

sr.ToImage(0, filePath + “.out.emf”);

Hi Shakeel,

Any update on this?
Thanks and Regards
Mukundan

Hi,

Thanks for your posting and using Aspose.Cells.

We have logged your comments in our database against this issue. Please spare us some time. Hopefully, you will get some ETA or fix for this issue.

We also advise you to download and try the latest version: Aspose.Cells
for .NET v7.4.0.2
and let us know your feedback.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed this issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.0.3 and let us know your feedback.

The issues you have found earlier (filed as CELLSNET-41309) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.