Free Support Forum - aspose.com

Incorrect TextBox Height


#1

I generated the attached powerpoint (Example.zip (26.5 KB)) which has two slides each with one textbox. The first textbox is reported in PowerPoint as being 11.67" tall, whereas Aspose.Slides reports it as being 7.341" tall, which is what PowerPoint is reporting as well. However, it doesn’t seem to be following PowerPoint’s “Resize shape to fix text” property, since if I set AutoFit to “Do not Autofit” and then back to “Resize shape to fit text”, it reports the expected height of 7.74".

I am using Aspose.Slides.NET v18.3. I just upgraded from v16.8, but it didn’t change this behavior.

PowerPointScreenShot1.png (198.6 KB)
PowerPointScreenShot2.png (161.2 KB)
Code.png (9.4 KB)
ShapeHeights.png (873 Bytes)

Is there something I need to do in Aspose.Slides to get the 7.74" height? Or is there a bug in Aspose.Slides affecting the height calculation?

I submitted a similar topic about table heights, too.

Thanks,
Charlie


Incorrect Table Height
#2

@cmathis430,

I have worked with presentation file shared by you and have been able to observe the issue specified. An issue with ID SLIDESNET-40574 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.


#3

@mudassir.fayyaz I’ve created a reproducer, which is attached below. It also includes a reproducer for Incorrect Table Height.

Reproducer.zip (9.3 KB)


#4

@cmathis430,

Thanks for sharing files with us. We will get back to you with good news soon.


#5

@Adnan.Ahmad,

Any update or timeline you can share on this? Thank you!


#6

@cmathis430,

I have observed your comments and like to inform that we have tried to reproduce issue with sample you shared but it has issues and no output was generated. Can you please share working sample project so that we may further investigate to help you out.


#7

@Adnan.Ahmad It probably wasn’t working because I purposefully deleted the license file, and I didn’t include a build since there’s a limit to how big a file I can upload to this comment system.

I’ve uploaded a fully built version to my dropbox. Please let me know if that works for you. Thanks.

https://www.dropbox.com/s/wuvw0jea002sbft/Reproducer.zip?dl=0


#8

@cmathis430,

Thank you very much for sharing requested file. We will get back to you with good news soon.


#9

Hi @Adnan.Ahmad, Was the reproducer helpful? Were you able to compile it and experience the issue I described? Thanks.


#10

@cmathis430,

I have observed your comments. I like to inform that issue is still under investigation and we will share good news with you soon.


#11

@Adnan.Ahmad Any updates? Thanks.


#12

@cmathis430,

I have observed your comments. I regret to inform that issue is still under investigation and we will share good details regarding ETA with you soon.