We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Installed app on a new server and seeing watermark when reports are exported

In 2014 a client of our purchased an Aspose.Pdf.Reporting Services license. This was done because we use SSRS to produce reports and they are run and export these reports via IE. The client needed to have the text in the reports export with full justification and SSRS does not have this functionality. So they run the reports in IE and export using the PDF via Aspose.Pdf option. When they did this the text in the report was fully justified.


This client recently migrated to a new server. Old server was using Microsoft SQL Server 2008 R2 and Visual Studio 2008. New server has Microsoft SQL Server 2012 and Visual Studio 2010. After they migrated we used the install file from the old server, v2.6 and installed aspose just like we did for them on the old server. We then took the license file from the old server and copied it into the License folder on the new server but each time we export a report from IE we see the watermark, "Evaluation Only. Created with Aspose.Pdf. Copyright 2002-2014 Aspose Pty Ltd."

I’ve chatted with the aspose help desk and they had me try and place the license file in various folders but all to no avail.

Please help.

Hi Alexandra,

Thanks for contacting support.

The license is validated during .RDL to PDF conversion and in case your license is expired before the release date of current version you are trying to use, you will get evaluation watermark. Can you please check tag inside license file and match it with release date of current API version. We are sorry for this inconvenience.

PS, if your license is expired and before you upgrade license subscription, you may consider requesting a 30 days temporary license to test the latest release. Get a temporary license

When we installed aspose.pdf for reporting services we used v2.6 and received the license at that time. When the new server was set up we had the v2.6 install file on the old server so we copied that over to the new server and installed v2.6 and applied the same license. Based on what you are saying it sounds like the license we have should work with v2.6. In addition, our license shows that it expired on 6/2015 but from 6/2015 through 2/2016 we were able to export documents without a watermark.


In short it looks like our license expired on 6/2015 but it should still work since we are using the old version of aspose.pdf for reporting services. That agrees with what the person on the chat told me…

[10:02 PM] Sabrina: Our licenses are perpetual with one year subscription. You can continue to use the versions that you have downloaded before the subscription expiry date but any new updates you would need to renew your license subscription first.

Since we installed v2.6 why is it no longer working?

thank you, Brian

Hi Brian,


Thanks for your feedback. We are looking into it and will update you soon.

We are sorry for the inconvenience caused.

Best Regards,

Hi Brian,


Thanks for sharing the details.

The version 2.6.0 which you have mentioned in earlier post was release on 5/5/2014 and your license file has an expiry date of 6/2015, so the license should work with mentioned release. Can you please share the license file, so that we can test the scenario in our environment. Please follow the instructions specified over How to send a license?

We are sorry for this inconvenience.