We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

License not detect on Server (Aspose Demo Tag still shown) - Aspose.Barcode.Reporting.Service

Hello,

We have installed the License and the Aspose.Barcode.Reporting.Service on our report server.

I have copied the license file to the production installation of Reporting service 2008 on our server. The componet renders and we get the barcode, but the barcode still has the Aspose tag on it (like on the demo).

I have the license installed on my development PC and everything works fine.

Our Installation locaton for reporting services is on the E:\ drive - would that cause an issue?

After copying the file to the production location, we restarted SQL reporting services and IIS.

We are running

SQL Reporting Services 2008

Windows Server 2003

IIS 6

thanks

Chet Borg

Polarsemiconductor Inc

Hi Chet Borg,


We apologize for your inconvenience.

Please mention the version of Aspose.BarCode for SSRS that you are using. You can check the version of your Aspose.BarCode assembly by finding the Aspose.BarCode.ReportingServices.dll in your SQL Reporting Services folder. At my end it is “C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin”, but the path will be different at your end (cause you have installed the SSRS to E drive). Check the snapshot attached for your reference.

Regards,

We are using version 2.6.0.0

In attempting to correct the problem and make sur that my license and my dll are not corrupt on the server. I have taken same DLL and license that I using on my developement PC and copied to to the server. After the update, I restarted Reporting Services and IIS.

The issue still persists.

Hi,


Thank you for providing the further information.

I have verified this behavior with Aspose.BarCode for Reporting Services v2.6. Please use the previous version of Aspose.BarCode for Reporting Services 2.5 until this issue (ID: 30440) is resolved.

For downgrading, please uninstall Aspose.BarCode for Reporting Services from control panel – Add remove programs, download v2.5 and install this one.

When you are done updating the assemblies, please place the license file in the same folder and restart the Reporting Services.

Regards,

Hello,

Still have the problem.

I uninstalled v2.6, installed v2.5, the copied the license file to \\e:\Program Files\Microsoft SQL Server\MSRS10.REPORTSRV3\Reporting Services\ReportServer\bin . I restarted Reporting Services Service.

Do I need a differnt license for the older version? Or is the original licanse backward compatitble.

thanks

Chet

Hi,


Your license has backward compatibility and should work with v2.5. Can you please make sure that the assembly in Reporting Services\ReportServer\bin folder is of v2.5? If not then please manually copy the assembly and restart the Reporting Services.


[Edited] Please also share the system specifications of your development machine. Have you installed the Reporting Services on E drive?

Regards,

Hello,

Production Server (Windows Server 2003 SP2, SQL Server 2008, IIS6)

In my latest attempt to get this to work, I uninstalled version 2.5. I then re-installed it on the e: drive (same place where SQL server 2008 is installed). I manually copied E:\Program Files\Aspose\Aspose.BarCode for Reporting Services\Bin\SSRS2008\Aspose.Barcode.ReportingServices.dll (Which I verified is 2.5.0.0) to E:\Program Files\Microsoft SQL Server\MSRS10.REPORTSRV3\Reporting Services\ReportServer\binE:\Program Files\Microsoft SQL Server\MSRS10.REPORTSRV3\Reporting Services\ReportServer\bin.

I stopped the "SQL Server Reporting Services" and restarted it.

Additional Information:

We are running this site on two servers accessing them through "Network Load Balancing". However, even when I access the sites indivually - we are still getting the Aspose watermark on the barcodes.

My Developement Computer is

Windows 7, SQL Server Express 2008 R2, Visual Studio 20008 Microsoft SQL Server Reporting Services Designers Version 10.50.1600.1

Hi,


Thank you for your testing.

In your reply, you haven’t mentioned the License file. Have you copied it to the Reporting Services/bin folder before restarting the services? If you have placed the license file and the watermark still appears, please try to create a new report, add just one barcode (re-add the barcode control of v2.5 on VS toolbox), deploy it. See if it has “Aspose” label on top.

If there is no progress with the issue then please send us your license file in an archive so we may test it under similar conditions. You can send the license by selecting the “Contact” button on your thread. Select “Send Babar.Raza an email” and attach the license archive with your email.

We apologize for your inconvenience.

Sorry, I thought you would see the license file in the screen capture (It was located right beneath the Aspose.Barcode.ReportingServices.dll). Yes, before I restarted the Reporting Service - I Did copy the license to the same directory as noted in the previous post ("E:\Program Files\Microsoft SQL Server\MSRS10.REPORTSRV3\Reporting Services\ReportServer\bin").

Per your request, I created completely new project, I removed the Aspose Barcode 2.5 Control from the toolbox. I added the control back to the Toolbox, then placed it on my report. I redeployed it, and the Aspose label is still on the top of the barcode.

I have emailed a license per your request.

Thanks

Chet Borg

Hi,


I am sorry to know that your issue isn’t resolved yet.

I have received your License file and we will test it very soon under similar conditions. We will keep you posted with updates.
Hi,

Just to bring in your knowledge that we have fixed the licensing issue reported under ticket Id : 30440. We are about to release a new version of Aspose.BarCode for Reporting Services with this fix.

We will notify you as soon as the new version is available for public use.

Thank you for your patience.

The issues you have found earlier (filed as 30440) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Ok, I downloaded and installed 4.1.1 on the server and my developement computer. It works on my developemnt computer but not on the server.

On the Server I

1.Uninstalled 2.5

2. Installed 4.1.1

3. Copied the license file and the Aspose.Barcode.ReportingServices.dll from C:\Program Files\Aspose\Aspose.BarCode for Reporting Services\Bin\SSRS2008 to E:\Program Files\Microsoft SQL Server\MSRS10.REPORTSRV3\Reporting Services\ReportServer\binE:\Program Files\Microsoft SQL Server\MSRS10.REPORTSRV3\Reporting Services\ReportServer\bin

3a. After i saw that there was no change and the watermark was still being displayed on the server - I copied the License file from email that Aspose sent when we purchased the product also - just to make sure. (I repeated 4 & 5 when I tried the license file from my email)

4. I stopped and restarted Reporting Service

5. I stopped an restarted IIS

On My Developement PC

1. Uninstalled 2.5

2. I installed 4.1.1

3. I opened Visual Studio and removed Aspose Barcode 2.5 from the toolbox.

4. I removed the Aspose Barcode Component 2.5 from the report

5. I add Aspose Barcode 4.1.1 to the toolbox

6. I added the Aspose barcode 4.1.1 component to my report

7. I re-deployed the report

8. Watemark is still being displayed on the server

Hi,


We are sorry for your trouble.

Before releasing, I have personally tested your provided License file with Aspose.BarCode for Reporting Service v4.4.1 under the same environment as of your production server (i.e SQL Server 2008 on Windows Server 2003). I am afraid on my end the license was set properly and no evaluation warning was visible in deployed reports.

After checking your latest results we set up another similar environment to re-test your issue. But again we are unable to reproduce the problem.

Can you reset one of your problematic servers, once done by-pass the load balancer and access the reports directly. Check if you still can see the evaluation label.

Hello,

I rebooted both servers, and I have the same issue.

When you said you tested my license in the same environment as my productions server - did you create a NLB Cluster, using the NLB Cluster software provide with Server 2003?

We are using the integrated "Network Load Balancing Manager" which is part of Windows Server 2003. My System Adminsitrator is not going to allow me to break apart our NLB (Network Load Balance) Cluster on our production servers to perform your requested test.

I have been asked if you have tested your product with Windows Server 2003 NLB Clustering?

Is there anything else I can do, any logs I can check? Without knowing how your licensing works, it is very diffecult for me to debug this.

Thanks
Chet

Hi Chet,


Thank you for your response.

Actually we tried using the load balancer in our test environment but load balancing with one host didn’t seem to work for us. So we reverted it back and then tested the issue.

We have logged a ticket in our bug tracking system with highest priority possible to probe further into this issue. We also have mentioned NLB Clustering in the description of the ticket and our development team is currently preparing the test environments for this purpose. The ticket id for your reference is 32714.

We believe, to solve such kind of problems there should be a connection between you and us in real time to debug and see the cause of the problem. Will it be possible for you to provide us the access to Remote Desktop or if you have any other ideas about establishing a remote connection then please share that with us. Once approved by you, we’ll ask you to manage a schedule for our development team.

Looking forward to hear from you.

I will something set up and get incontact with you early next week.

thanks

Chet

Hi Chet,


Thanks for your positive response.

We are looking forward to hear from you.

Regards,

Hello Babar,

My System Administartor would like to know if you have a way that you generally work with clients when remoting into there systems (Webex, GoToAssist, or OfficeLive Meeting). We have never initiated one of these sessions but have worked with lots of venders that have.

I also have been asked about what your development team plans to do when remoting into our servers (Theses are live servers running a manufacturing facility, you would be aloud to validate installation of your product, but you would not be aloud to make any configuration changes to the server or its software.)

It also appears from the timestamp on your replies that we may have diffeculty in arranging a meeting during normal business hours here in Minnesota (United States).

I am being pressured by Management to ask for a refund and find another vender.

Please addresss the above concerns.

thanks

Chet