We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Missing field buttons in Pivot Chart

When creating a pivot chart, with the code, as shown in the example, the field buttons are missing:

http://www.aspose.com/docs/display/cellsnet/Create+Pivot+Tables+and+Pivot+Charts

When I open the generated file in Excel 2013, I have to select the following manually, to get them to display:
PivotChart Tools->Analyze->Show/Hide->Field Buttons

I then have to manually select each of the field buttons.

Note I have set pivotChart.HidePivotFieldButtons = false;

Hi Chris,


Thank you for considering Aspose APIs.

We have evaluated your presented scenario while using the latest version of Aspose.Cells for .NET 8.3.0.3, and we are unable to replicate the mentioned issue. The Pivot Field buttons (-/+) are displayed by default when resultant spreadsheet is loaded with Excel 2013 application. Attached is the resultant spreadsheet from our end.

Please give a try to the latest version (link shared above). In case the problem persists please provide us the spreadsheet generated on your side while using the v8.3.0.3 of Aspose.Cells for .NET. Moreover, if you have amended the code from the referenced article then mention those changes as well.

Hi again,


Sorry, my previous response covers only half of your inquiry as I believe you have referred to the Pivot Field buttons in the Pivot Chart. Please have a look at the attached snapshot highlighting the desired buttons. Aspose.Cells for .NET 8.3.0.3 (download link shared in previous response) shows these buttons without any manual efforts. Please check the resultant spreadsheet for your reference, and feel free to contact us back in case you have more questions or concerns.

This still doesn’t work.


I’ve attached the output file, after updating to 8.3.0.3 and using your supplied code.

You will see, on the PivotChart worksheet, there are no Field Buttons. I have to manually switch them on afterwards, in the ribbon for Pivotchart Tools.

Hi Chris,


Thank you for writing back, and we are sorry you know that you are still experiencing the said problem on your end. Upon reviewing your resultant spreadsheet, we have noticed that the field buttons are not visible (by default) on the Pivot Chart. At the moment we are not sure what could be causing the diverse results therefore we would request you to please share a sample console application along with all its dependencies for further review. Please also provide the version information of your Excel installation as exhibited in the attached snapshot.

Looking forward to your sample application to sort out this issue at earliest possible.

There’s no point in sending my code.


If I save the file as an xls file, as per your example, it works. If I save it as an xlsx it doesn’t.

Note that in my real application I’m saving to a stream, as follows:
workbook.Save(reportStream, SaveFormat.Xlsx);

Hi Chris,


Thank you for providing more information.

We are able to replicate the problem of Missing Field Button for the Pivot Chart while saving the resultant spreadsheet in XLSX format. We have logged the problem in our bug tracking system under the ticket CELLSNET-43210 for further investigation & correction purposes. Please spare us little time to properly analyze the problem cause, and to provide the fix at earliest possible. In the meanwhile, we will keep you posted with updates in this regard.

What is the time-frame for such fixes to be made?


As is fairly typical, this is one of the last changes I’m making to my product before readying for release, so it is a crucial period of time for us.

Hi again,


I am afraid, we cannot share the estimated release schedule for the fix unless we have properly analyzed the scenario to isolate the problem cause. As we have just added this ticket to the queue, it is currently pending for analysis so you have to wait a little to get a concrete ETA.

Please note, we publish a maintenance release once a week. If the aforesaid issue isn’t hard to fix, we may provide its fix in a week or two.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET v8.3.1.1

We have fixed your issue now.

Let us know your feedback.

Thank you.

Thank you for finding the time to fix, however, I’m no longer in the position to do so. We are making no further changes to the project, so its non-function has meant that we have had to find another solution (using standard tables and charts).

Hi Chris,


We are sorry that we took a little long to provide the fix for the issue as discussed in this thread. Hopefully, you are still using Aspose.Cells API in you project, and soon you will incorporate the said feature in your application.

Please note, we are going to close the ticket CELLSNET-43210 for now. In case you find some problem in this feature or any other part of the API, we can handle it under the new ticket. Please feel free to contact us back in case you need our further assistance with Aspose APIs.

The issues you have found earlier (filed as CELLSNET-43210) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.