Free Support Forum - aspose.com

Mono compilation problem

Dear Sirs!

I now try to use your last Aspose.Cells.DLL 7.4.1.2 to compile my program under Mono. But failed

$ gmcs -r:Aspose.Cells.dll Program.cs
error CS0009: Metadata file /home/pdvorkin/test/Aspose.Cells.dll' does not contain valid metadata
Compilation failed: 1 error(s), 0 warnings

CentOS 5.7

Mono JIT compiler version 2.11.4

With best regards,

Pavel Dvorkin

Hi,


Could you elaborate your issue more.
As per your other thread (http://www.aspose.com/community/forums/1/453619/mono-problem/showthread.aspx), you got only “Unknown Heap Type : SmartAssembly” error which accordingly to you it was just a warning message and does not effect the working of the assembly (http://www.aspose.com/community/forums/permalink/453619/453619/showthread.aspx#453619). There, your mono version was 2.8. Here, your mono version is 2.11.4. Could you give us more details about it and also, paste your sample program or code here, we will investigate it further.

Also, we highly recommend you to kindly try our latest version/fix: Aspose.Cells for .NET v7.4.2.

Thank you.




Earlier I build my application in Visual Studio and tried to run in Mono. I got "Unknown Heap Type : SmartAssembly".

Now I am trying to build this application in Mono usign Mono C# compiler. And fail.

Yes, I switched to last stable release of Mono 2.11.4

Tried Aspose.Cells.dll 7.2.4. The same

As for sample program, you can use any program which uses Aspose.Cells.Dll because I can't build the program at all.

E.g. try this

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.IO;
using System.Configuration;
using Aspose.Cells;

namespace Convertor
{
class Program
{
static void Main(string[] args)
{

Workbook book = new Workbook("template.xlsx");

}
}

}

Mono C# compiler considers your DLL as having wrong metadata . It is compile-time problem. I think this problem is because your Dll is obfuscated,

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.2.1 and let us know your feedback.

The same

$ ls Aspose* -l

-rw-r--r-- 1 pdvorkin ldapusers 7165272 Мар 27 16:26 Aspose.Cells.dll

$ gmcs -r:Aspose.Cells.dll test.cs
error CS0009: Metadata file `/home/pdvorkin/test/Aspose.Cells.dll' does not contain valid metadata
Compilation failed: 1 error(s), 0 warnings

BTW. Is it 7.4.1.2 or 7.4.2.1 ? Your link text says 7.4.2.1 while dowloading file name is "Aspose.Cells7.4.1.2+For+.NetClient.zip" .


Hi,


Sorry for the confusion.

Please find attached and try our latest fix/version: Aspose.Cells for .NET v7.4.2.1 (compiled on .NET 2.x and targeted for any CPU with any of the normal .NET framework versions greater than or equal to 2.x (i.e. 2.x, 3.0, 3.5, 4.0, 4.5 etc.)).

I have tested using the attached fix, it works without any SmartAssembly warning issue/exception or other issue.

Thank you.

Thank you very much. No problem with compilation. No "Unknown heap".

With best regards

Pavel Dvorkin

Hi,


Thanks for your feedback.

Good to know that your issue is resolved.

Feel free to contact us any time if you need further help or have some other query/issue. We will be happy to assist you soon.

Thank you.

One question. I do not see this 7.4.2.1 in your official releases list. So now I am the only developer which has access to it :-)

Will it be put there ? Or can I be sure that next official release will contain these changes ?

With best regards

Pavel Dvorkin

Hi,

Yes, sure you may use this fix (v7.4.2.1) as long as you wish without any problem, it will behave like an official release in your production server. it contains all the full fledged features/functionality of v7.4.2 till current fixed version. It is an intermediate kind of version which is provided as a fix against some bugs and new features/enhancements. Normally, a bug fix version is posted in the support forums for our clients. Moreover, it is to be noted that our next official release (i.e. v7.4.3 (probably) -- before the end of April 2013 hopefully) would include all the functionality of the previous fixes (including this one too).

Thank you