We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

MVN repository changed?

hi

We are using enterprise version , look like MVN repo ULR got changed recently which affect us in artifactory
here is the URL we are configured http://maven.aspose.com/artifactory/simple/ext-release-local/

Let me know if this is changed ?

@divakumaran,

Please note, http access has been disabled due to security reasons. Our repository URL is https://repository.aspose.com/repo/ which is only accessible through Maven or Gradle clients. You can explore our repository through https://repository.aspose.com/webapp/#/artifacts/browse/tree/General/repo.

For example, you may update your maven configurations as below:

....
<repositories>
<repository>
<id>AsposeJavaRepository</id>
<name>Aspose Java Repository</name>
<url>https://repository.aspose.com/repo/</url>
</repository>
</repositories>

Thanks
We are getting below error when we use https://repository.aspose.com/repo/

[ERROR] Failed to execute goal on project inin-document-conversion-service: Could not resolve dependencies for project com.inin.document.conversion:inin-document-conversion-service:jar:0.0.1-SNAPSHOT: The following artifacts could not be resolved: com.aspose:aspose.imaging:jar:jdk16:21.12, com.aspose:aspose-slides:jar:21.12: Could not find artifact com.aspose:aspose.imaging:jar:jdk16:21.12 in inin-artifactory-mirror (https://articache.ininica.com/artifactory/inin-maven-mirror-remote) -> [Help 1]

@divakumaran,

It seems you are getting issue for Aspose.Slides for Java and Aspose.Imaging for Java API only and other Aspose for Java APIs are imported ok from the repository. We split and created new threads in respective forums for the issue where you will be assisted accordingly soon.

What should be the URL i need to configure in Artifactory ? It was configured as http://maven.aspose.com/artifactory/simple/ext-release-local/ which is not working any more . As you know Artifactory is another application used for artifacts caching . Could you please give me correct URL for this , Ignore my other error messages

@divakumaran,

As I told you we have disabled http access due to security issues. Our suggested repository is only accessible through Maven or Gradle clients. Anyways, we will get back to you soon for your queries.

@Amjad_Sahi It is not about the http or https

We are using JFROG Artifactory for artefact caching and we configured Aspose Repository as Remote repo in JFROG , we were used http://maven.aspose.com/artifactory/simple/ext-release-local/ to connect the Aspose REPO , this is not working now and we blocked

can you please suggest what is the alternative URL so that i can configure it in JFROG to connect aspose REPO

@divakumaran,

I am afraid, there is no other URL for our repository except the following:
https://repository.aspose.com/repo/

We discarded Artifactory and we have now switched over to AWS.

@divakumaran,

We have retired JFROG Artifactory and move our repository over to AWS and Hugo.
Web UI URL is https://repository.aspose.com/
Repository (repo) URL is https://repository.aspose.com/repo/

You can use Maven/Gardle clients to download our artifacts. Sorry we no more support Aspose repository as remote repository in JFROG.

Sorry for any inconvenience caused!

Thanks @Amjad_Sahi , now I am clear that why it not working as earlier , thanks for your support

@divakumaran,

You are welcome.