We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Named range not properly created in 21.5 but worked in 21.4

Hi,

We got this problem already, but it was in 2018: Named Range not properly created in 18.8, but worked in 18.3

It also works with the attached samples from link above.
21.4 works, 21.5 not.

Hope this finds its way in a unit test.

@IT_Helpdesk,

We will evaluate your previous test case (in other thread) with latest version soon.

In case, the issue is different (from the previous one), kindly do provide new test case (resource files, test code and screenshots, etc.) to reproduce the issue. Also, give details about your environment and other configurations (if any). We will check it soon.

@Amjad_Sahi: The result is different (Earlier it had a translation problem, now it is just invalid -> =#NV), but not correct:
OK:
grafik.png (3.9 KB)

NOK:
grafik.png (3.2 KB)

	private static void NamedRangeWorkbookTest()
	{
		const string srcFilePath = @"C:\c2k\TEMP\DataSheetTests\AsposeTests\NamedRange\NamedRangeTest.xlsm";
		const string tgtFilePath = @"C:\c2k\TEMP\DataSheetTests\AsposeTests\NamedRange\NamedRangeTest_Tgt.xlsm";

		const string name = "HasFormula";
		const string value = "=GET.CELL(48, INDIRECT(\"ZS\",FALSE))";

		Workbook wbSource = new Workbook(srcFilePath);
		WorksheetCollection wsCol = wbSource.Worksheets;

		int nameIndex = wsCol.Names.Add(name);
		Name namedRange = wsCol.Names[nameIndex];
		namedRange.RefersTo = value;

		wbSource.Save(tgtFilePath);
	}

NamedRange.zip (17.6 KB)

@IT_Helpdesk,
We have observed this issue using the latest version whereas it worked fine with the previous version. This issue is logged in our database for further investigation. We will notify you here once any update is ready for sharing.

This issue is logged as:
CELLSNET-48086 - Named range not properly created in 21.5 but worked in 21.4

@IT_Helpdesk,

This is to inform you that the issue has been resolved. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes. You may expect the fix in the next few days.

@IT_Helpdesk,
Please try our latest fix
Aspose.Cells21.5.4 For .Net2_AuthenticodeSigned.Zip (5.5 MB)
Aspose.Cells21.5.4 For .Net4.0.Zip (5.5 MB)
Aspose.Cells21.5.4 For .NetStandard20.Zip (5.5 MB)

@johnson.shi: Works like a charm. Thank you.

Hope this does not happen again.

@IT_Helpdesk,

Good to know that your issue is fixed in the new fix.

And, sure, we hope this won’t happen again.

The issues you have found earlier (filed as CELLSNET-48086) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao