Free Support Forum - aspose.com

PDF-Printed incomplete via PDF.Kit

Dear Aspose-Team,

I am sometimes having the problem, that certain PDF-Files are not printed correctly when printing via pdf.kit. If I print them with Acrobat or other reader, it works fine. I am using the most recent version of the .dll (.net 2.0 5.3.0.0)

Problem: The "Frame" of the Document is printed, but certain information are missing. In this special case, an invoice, I see the header and all, but the product lines are not printed.

I attached an example file to this post.

What can we do?

Thanks a lot,

Michael

Dear Aspose Team,

could you reproduce the problem or do I have to provide more information?

Regards,

Michael

Hi Michael,

We’re looking into this issue at our end and you’ll be updated with the status shortly.

We’re sorry for the inconvenience and appreciate your patience.
Regards,

Hi Michael,

I have reproduced this problem at my end and logged it as PDFKITNET-24573 in our issue tracking system. Our team will look into this issue and you’ll be updated via this forum thread once it is resolved.

We’re sorry for the inconvenience.
Regards,

Dear Aspose Team,

do you have any news on this issue?

Thanks a lot,
Michael

Hi Michael,

I’m sorry to share with you that this issue is not yet resolved. However, I have asked our team to share the ETA of this issue. You’ll be updated as soon as the response is received.

We’re sorry for the inconvenience.
Regards,

Hello,

here another document which is handled incorrectly. I scanned the printout and attached it and the original file to this post. Maybe this helps.

Many thanks,

Michael

Hi Michael,

We’ll investigate the issue with these documents as well and update you accordingly.

We’re sorry for the inconvenience.
Regards,

Hi Michael,

I have tested this file using the latest hot fix and produced the printed output correctly. Please download the hot fix from this link and try at your end. If it still doesn’t resolve your issue then please do let us know.

We’re sorry for the inconvenience.
Regards,

Dear Aspose-Team,

I just tested the Hotfix and some Documents work now, but still the Document from my first post is printed incorrectly. And it seems like the Hotfix component sometimes hangs when printing multiple documents in a row.

I attached the file which is incorrectly printed to this mail (article rows are not printed).
Please keep me up to date.

Regards,

Michael

Hi Michael,

The file you attached with your last post is the same as the one you shared in your first post. I’m afraid, the issue with this file is not yet resolved; as you know, this had already been logged in our system and our team is looking into it. The hot fix only worked for the second file – the one you shared in your previous post (correct.pdf).

You’ll be notified via this forum thread once we resolve the issue with the other file.

We’re sorry for the inconvenience. If you have any further questions, please do let us know.
Regards,

Dear Aspose-Team,

can you foresee when an update will be available?
I am getting more and more PDFs which are printed incorrectly.. maybe there is a general bug in the printing component?

Thanks a lot,
Michael Eberhardt

Hi Michael,

Our team has further investigated this issue and I would like to share with you that the fix for this issue will be available at the end of May 2011. You’ll be notified via this forum thread once it is resolved.

We’re sorry for the inconvenience. If you have any further questions, please do let us know.
Regards,

Dear Aspose Team,

so you are saying I cannot properly use the component I bought until the end of may?
This is not very satisfying. This component is really quite important for me, what can we do to get the fix quicker? I just need the printing-feature..

This would be really nice!
Regards,

Michael Eberhardt

Hi Michael,

I would like to share with you that our team always try to provide the resolution as early as possible; however, I’m afraid, we need to deal the issues and requirements on first come first serve basis. As there are already a couple of issues under process, the team has scheduled this issue accordingly. Nevertheless, I have increased the priority of this issue to ‘high’ and we’ll see if this issue can be adjusted and resolved earlier; however, I’m afraid, we can’t promise that at the moment.

We’re sorry for the inconvenience and appreciate your cooperation. If you have any further questions or concerns, please do let us know.
Regards,

Hi Michael,

I would like to share with you that our team has rescheduled this issue and we’ll try to provide you the fix at the end of April 2011.

We’re sorry for the inconvenience.
Regards,

Dear Aspose-Team,

I attached another bunch of PDF-Files to this post which are printed incorrectly.
Currently I am not very happy with the situation as it seems to me like the majority of PDF-Files is printed incorrectly rather than correctly. I bought the Aspose-components because of the good reputation I found in the web. But right now, I have to wait until the end of April until I hopefully get a fixed version which solves the problems. I hope the attached files help to get this issue fixed earlier.
Or are my PDF-Files that exotic..?

Regards,
Michael Eberhardt

Hi Michael,

First of all, I apologize for the discomfort caused due to these issues.

Secondly, I would like to share with you that usually these kinds of issues might occur due to the particular content or structure of the PDF files. Our team tries to cater these scenarios; however, sometimes certain new scenarios still cause problem. We’ll try to resolve these issues the earliest possible.

Lastly, I have tested the files you shared and I would really appreciate if you could share some more details regarding these issues, for better understanding. The file you shared in your first post was having problem of missing contents when printed. However, I could only notice such problem with one file – FD3120819.pdf – and this file is the same as the one you shared in your last post; so this issue is already logged and our team is working on it.

The other two files – Grundriss-1.pdf and Mechtold 087119_Grundriss.pdf – when printed show the contents rotated by 90 degrees. While, I couldn’t notice any such problems with the remaining files.

Could you please share the details of the issues with each of these files? This will help our team focus on those particular areas and provide you the resolution accordingly.

We’re sorry for the inconvenience and appreciate your cooperation.
Regards,

Dear Aspose-Team,

I attached an archive with scans of the incorrectliy printed documents.
You are right, some docs are rotated, but on others elements are missing.
The hotfix I got from you fixed a few, but not all problems.

Thanks a lot,

Michael Eberhardt

Hi Michael,

I have reproduced the issues where the printed output is rotated. These issues have been logged as shown below:

PDFKITNET-25529 - Grundriss-1.pdf
PDFKITNET-25530 - Mechtold 087119_Grundriss.pdf

However, I’m still unable to produce the issues with the following files:

55_Bestelländerung.pdf
888_Austauschbestellung.pdf
Bestellung-1.pdf

These files are printed perfectly when Aspose.Pdf.Kit for .NET 5.4.0 is used. Could you please make sure that you’re using the latest version at your end? If you still find the same problem with the latest version as well then please share some more details regarding your working environment: .NET Framework version, OS, development environment etc.

We’re sorry for the inconvenience and looking forward to help you out.
Regards,