Free Support Forum -

PPTX to PDF: EMF files missing (Azure .NET)

We’ve got an issue with Aspose Slides on Azure.

When deploying a very simple Web app to Azure and converting a PPTX that contains EMF pictures (like charts) to PDF, these EMF files will not always show up in the converted PDF.

The same thing does work fine when running the application locally, but as soon as we deploy it to Azure, it stops showing the converted EMF pictures in the PDF.

We’re using Aspose.Slides for .NET version 18.9.0, which currently is the latest version.

If I look through your Release notes I see several fixes that might be related:
SLIDESNET-35700 PPT Charts not showing in PDF conversion with Azure Websites
SLIDESNET-38204 - EMF images are not properly rendered in generated pdf

I’ve tried setting the SaveMetafilesAsPng property on Aspose.Slides.Export.PdfOptions to true and false, both options do not help though. I’ve even tried looping through the available presentation.Images collection and converting them to JPG by some c# function and using image.ReplaceImage to update them. This does not work either.


I have observed your comments. Can you please share source files along with generated result so that we may further investigate to help you out. Also please share environment details with us.


Included you’ll find a few things:

  1. A demo excel file from which I copied information:
  2. The PowerPoint file to which I copied the information in various ways:
  3. The resulting PDF:
  4. The source code of the Web Application:

You can test this yourself by opening our test azure App Service:

Upload the Presentation2 file and click Convert. It will send you a Converted.pdf file just like the one I included in this post.

As you will see, various ways of posting result in missing images: pasting as picture, EMF, WMF.

If I run this web application locally, it will contain all images though, so the problem is confined to Azure.

Azure config
This is ‘Just an App service’ created through the Azure Portal running on a Free App Service plan. I changed nothing to the Application Settings:

  • Running on .NET 4.7
  • Managed Pipeline version: Integrated
  • HTTP version: 1.0
  • Platform: 32bit

This same results I ran into on another app Service running on 64 bit, HTTP version 2.0, and a higher App Service Plan.


Thank you for sharing the details with us. An issue with ID SLIDESNET-40596 has been created in our issue tracking system to investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.


Any updates about this? We really need a solution for this.

Kind regards


I regret to share that the issue specified is not yet resolved because issue is added recently in our issue tracking system. Actually, in Aspose.Slides forum the issues are selected for investigation on first come first serve basis. Also the first priority for scheduling and resolution is given to paid Enterprise and priority support customers. Then Aspose.Slides normal or free support customers issues are scheduled and resolved on first come and first come serve basis. I will share the further information with you as soon as the issue will be resolved.

So what would be the expected time for an issue such as ours to be taken up?

I mean of course the time it takes on average for issues to be taken up.


The issues are selected for investigation based on first come and first serve basis. Then after investigation, based on complexity of issues the issues are selected for resolution. We will really appreciate your patience in this regard till the time the issue is investigated and resolved.

We are a paid support customer and we are having similar issues. We have a PPTX with EMF images. the PPTX is fine but when creating a PDF from the PPTX the text does not show up only lines. When we set
oPDF.SaveMetafilesAsPng = true; then it the PDF shows the correct data but they are PNGs instead of EMFs. This was working fine with Slides.Net Verison 17.12.1. The code is below

Aspose.Slides.Export.PdfOptions oPDF = new Aspose.Slides.Export.PdfOptions();

            //Set Jpeg Quality
            oPDF.JpegQuality = 90;
            //Set Text Compression level
            oPDF.TextCompression = Aspose.Slides.Export.PdfTextCompression.Flate;

            //Define the PDF standard
            oPDF.Compliance = Aspose.Slides.Export.PdfCompliance.Pdf15;

            pdfFileName = _repFileHelper.SaveReport(pptNewPresentation, "PDF\\", pdfFileName, Aspose.Slides.Export.SaveFormat.Pdf, oPDF);

We are currently running Slides.Net version 19.4, .Net Framework 4.5.1.


Can you please share source file along with generated result so that we may further investigate to help you out.


Since you are a paid support customer, you may also consider opting Paid support help desk for the resolution of issue. If you want to use free support for verification and resolution of issue then please also provide the source file and generated output for reference as well.

Hi guys,

It’s been almost a year since this discussion started. Has anything been planned for workloads on Azure?



I like to inform that we have started working on this and ETA is 2019’Q3. I request for your patience and we will share good news with you soon.


Are there any updates on the work thats being done on this topic?
What is the release date?

Kind regards,


I like to inform that this issue will be tentatively resolved in Aspose.Slides 19.10 and we will share good news with you soon.

Hi Adnan,

Is het correct that I do not see any changes when using Aspose.Slides 19.10?



I like to inform that issue is still in process and we will share feedback regarding ETA soon.

Are there any updates on this? It’s very frustrating for us that a solution of this issue has been delayed so long. We’ve got users who’ve been waiting for this update a long time. And when the wait finally seemed over (as per the promise this would be included in Release 19.10) the wait is lengthened indefinitely with a vague promise of feedback soon. As you can understand, we cannot sell this to the people using our product. And I hope you feel the same way.

If the issue cannot be resolved because of techical reasons, please do say so, that would at least give us clarity if not a solution. This not delivering of promised solutions and vagueness about the way forward makes us loose faith in using Aspose for current and future projects.


I have verified from our issue tracking system and even have discussed this internally. We have raised the priority of the issue as well and tentative ETA for the issue is Aspose.Slides for .NET 20.1. We will share the good news with you as soon as the issue will be fixed.