We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

"Do not compress images in file" setting changed

Hi,


Is there a way to set the “Do not compress images in file” Excel setting to checked? I am having difficulties finding information about this excel setting using Aspose.Cells; is this option available and editable in code using Aspose.Cells?
I asked because we are opening an excel file that has this setting ticked, but when the file is saved using Workbook.Save(), the item is unticked in the generated file.

The setting can be found in excel’s {File} -> {Options} -> {Advanced} -> Under {Image size and quality}.
Hi,

Thanks for providing us details.

After an initial test, I have observed the issue as you have mentioned. The settings i.e.., {File} -> {Options} -> {Advanced} -> Under {Image size and quality} is off although I have checked the checkbox in the template file manually. Here is sample code that I am using. I simply used a template file where I manually check the check box "Do not compress images in file" but when I opened the output file (by Aspose.Cells) into MS Excel, the checkbox is unchecked.

Sample code:

var wb = new Workbook(@"e:\test2\withoutcompress_bk.xlsx");
wb.Save("e:\\test2\\outwithoutcompr.xlsx");

I have logged a ticket with an id "CELLSNET-41629" for your issue. We will look into your issue to sort it out soon.

Thank you.


Thank you for confirming he issue.

Hi,


I would like to add that saving an excel file as a PDF using “Workbook.SaveAs()” the image inside a worksheet’s size is changed (disproportionately). This may be related to the setting in this topic.

Thank you.

Hi,

For : "I would like to add that saving an excel file as a PDF using “Workbook.SaveAs()” the image inside a worksheet’s size is changed (disproportionately). This may be related to the setting in this topic."

Please check the print preview of the sheet in MS Excel, your rendered PDF file should have the similar view of the image as shown in MS Excel’s print preview. If you have a different opinion, please create a new thread with all the details, e.g. sample code, template Excel file, the output PDF file etc., we will check it soon.

Thank you.

Hi,


Please try our latest fix/version: Aspose.Cells for .NET v7.4.3.1

We have fixed your issue now.

Let us know your feedback.

Thank you

The issues you have found earlier (filed as CELLSNET-41629) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.