We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Support for OpenType Fonts in Aspose.Slides (C# .NET)

I have a process that is generating thumbnails of slides and it appears that the fonts are working with TrueType Fonts but not with OpenType Fonts. Can you confirm whether or not Aspose.Slides supports Open Type Fonts?


Thanks!

Hi Cory,


I feel this should work. I would really appreciate if you may please share the presentation with us for necessary investigation on my end.

Many Thanks,

I just sent you a PM with the font file for your testing. Thanks!

Hi Corry,


Can you please share the presentation as I am afraid that you hive missed to share the presentation in your last post.

Many Thanks,

Sure, here is a sample presentation file using the font that I sent via PM.


http://www.mediafire.com/file/rdf66sfau202vxp/Testing%20a%20gotham%20font_001.pptx

Hi Corry,


I have worked with the presentation file shared by you and have been able to identify the improper rendering issue even if Gothom Book font is installed in operating system. An issue with ID 31806 has been created in our issue tracking system to further investigate and resolve the possible issue. This thread has been linked with the issue so that you may be automatically notified once the issue is resolved. I have also shared the generated PDF for your reference.

Many Thanks,

Any updates on this ticket? It has been months with no resolution. We have many frustrated users.

Thanks

Hi Corry,


I have used Aspose.Slides for .NET 6.0.0 and tried generating slide thumbnail and PDF. I feel them identical with shared presentation. For your kind reference, I have also attached the generated output. Please share, if you feel disagreement in this regard.

Many Thanks,

I just want to clarify, this is with an opentype font? Also is this a new version of the Slide Program?

Hi Corry,


I am sorry I did not understand the first part of your question. What I did is that I installed the font shared by you in my Operating System. Then I generated the thumbnail and PDF using latest available version of Aspose.Slides for .NET 6.0.0. Then I observed the PDF & thumbnail and compared them with presentation. I found them identical and same has been shared with you.

Many Thanks,

Sorry for the confusion. In our current enviromnent, the Apose slides are not converting our fonts into the thumbnail previews. When we tested this, the opentype fonts seemed to be the culprit. Has there been an update to resolve this. This is part of the orginal ticket Cory submitted.


Thanks

Hi Corry,


I like to share that according to our issue tracking system the issue has not yet been scheduled for investigation and resolution owing to already pending enterprise support, priority support and other issues. However, when I test the presentation shared by you by installing the font provided by you using Aspose.Slides for .NET 6.0.0, the output was fine. I shared the same with you. So, when our development team will work over the issue, they will also not be able to observe the issue and will mark it as resolved. I hope this clear the issue.

Now, if things are not rendering fine on your end then please share the complete sample presentation that is failing to get properly rendered on your end along with the custom fonts that you are using on your end. The presentation that you have shared with us is rendering fine using Aspose.Slides for .NET. I have also shared the steps that I have followed in for generating PDF with given presentation. Please share further so that I may be able to reproduce the same on my end as well.

FYI: I am using Windows 7 x64.

Many Thanks,

Attached is screenshots of how its supposed to look and how it currently shows in the Thumbnails

Hi Corry,


I have observed the issue in shared screen shots. In order to reproduce the same issue on my end I request you to kindly share the source presentation with us of shared screenshot with us so that we may try help you out further. Please also share the custom fonts if they are used in your presentation. Please also share the complete information related to your environment setup. Please also share that have you generated the thumbnails using Aspose.Slides for .NET 6.0.0.

Many Thanks,

Attached is a rar file will any opentype font that we may use for these presentations and the presentatons themselves. Let me know if you need anything else.

Thanks

Hi Corry,


Thanks for sharing the information. I have worked with new set of presentations and have been able to verify the issue as well. I have raised the priority of the issue to High as well and it will now be considered in High Priority issues queue which is the maximum priority level for Aspose.Slides forum support.The High priority levels comes after Priority support and Enterprise support levels that are among paid support.The issue will be addressed by development team and as soon as some response will be available, I will be glad to share that with you.

Many Thanks,

Any updates or ETAs?

Hi Corry,


Please accept my apologies for the delayed response.

Our development team has scheduled the issue for investigation by Week 14 of 2012. We will be able to share any ETA with you on the basis of investigation carried by our development team after the mentioned week. We will really appreciate your cooperation in this regard.

Many Thanks,

Were pretty much at Week 14, any updates?

Hi Corry,


I have recived response from our development team. Actually, at present support of open-type fonts is very limited to possibilities of GDI+. Any font which GDI does not support will be replaced by Arial Unicode MS.

Additionally, in second half of 2012 the completion and integration of DrawingMLRenderer project where work with fonts is based on Aspose.Font will be completed and it will have support for almost all open-type fonts. Up to this point we can’t solve this problem because of dependence on GDI+.

We are sorry for your inconvenience,