We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Support for Python 3.7 PIP in Aspose.Email (Python via .NET)

Following directions from:
https://docs.aspose.com/display/emailpythonnet/Installation
I get the error message:
Aspose.Email_for_Python_via_NET-18.7-py3-none-win_amd64.whl is not a supported wheel on this platform.
Or:
Collecting Aspose.Email-for-Python-via-NET
Could not find a version that satisfies the requirement Aspose.Email-for-Python-via-NET (from versions: )
No matching distribution found for Aspose.Email-for-Python-via-NET

PIP version: 19.0.3
Python version: 3.7.2
OS version: Win10 1803

1 Like

How am I supposed to determine if I want to buy the software if it’s installer doesn’t even work?

1 Like

Any chance I can get some support on this? Am I supposed to use a different version of PIP or Python? This is pretty straight forward… I’m typing a command and your wheel is failing.

@jlefebersccwi,

I have observed the issue information shared by you. An issue with ID EMAILNET-39459 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Thank you for the update.

Any further update on this issue, @mudassir.fayyaz ?

@jlefebersccwi,

I like to inform that issue has been added recently in our issue tracking system and pending for detail investigation. I request for patience and we will share good news with you soon.

@jlefebersccwi, @Adnan.Ahmad

When I try to install the Python wheel, pip fails with the error:

ERROR: Package ‘Aspose.Email-for-Python-via-NET’ requires a different Python: 3.7.2 not in ‘>=3.5,<3.7’

so I’m guess that’s also your error, Jonathan.

Could Aspose change the wheel, please? It looks like the only breaking changes in 3.7 are that async and await are now reserved words … which shouldn’t be a problem, yes?

Or can someone edit the wheel?

– Graeme Williams

@jlefebersccwi,

I have verified from our issue tracking system and like to share that at present Aspose.Email for Python via .NET supports python 3.5 and 3.6. An issue with ID EMAILNET-39538 has been created in our issue tracking system to investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the support will available.

A post was split to a new topic: Aspose.Email for Python version via .NET