Free Support Forum - aspose.com

Document Map support

I have a report that uses the Document Map feature of SSRS on a report item which gives a bookmark listing on the left side of the exported PDF when using the Microsoft PDF rendering extension. Using the Aspose rendering extension on this same report creates a corrupted pdf unles the Document Map value of the item is cleared.

Attached is an RDL from a very simple report written against the Northwind database that demonstrates the issue.

Thanks,

Kevin

Hi,

Can you please provide the database "Northwind 2007.accdb" because when I've tried binding the report with my SQL Server instance hosting Northwind database I'm unable to test the scenario. I'm getting "The Group expression for the list ‘list1’ refers to the field ‘Company’. Report item expressions can only refer to fields within the current data set scope or, if inside an aggregate, the specified data set scope".

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for sharing the resource file. But I'm afraid I'm unable to access it, may be it requires some login credentials, for which I'm not sure. Can you please share the required information.

I've tried using sa as user name and sa as password. Also I've tried the Admin as username, but no luck.

Ps, I'm getting following error message.

Strange, I was able to connect to it without specifying any credentials. As an alternative, I downloaded and installed the SQL2005 Adventureworks database and created another example against it that demonstrates the issue. The RDL is attached.

Thanks,

Kevin

Hello Kevin,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for sharing the resource file.

I'm not sure why I wasn't able to open the database in my previous try. Every time I accessed it, I prompted me for the login credentials.

Beside this, I've tested the scenario while using Adventureworks database and I'm able to notice that when using Map feature of SSRS on a report item, and when using Aspose.Pdf for SSRS, the resultant PDF is being corrupted.

For the sake of correction, I've logged it in our issue tracking system as PDFREP-10873. We will investigate this issue in detail and will keep you updated on the status of a correction.

We apologize for your inconvenience.

Hello Kevin,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your patience.

I'm pleased to inform you that, the issue reported earlier as PDFREP-10873, have been resolved in the attached hotfix. Please try using it and in case you still face any problem or you've any further query, please feel free to contact.

I've also attached the sample output file that I've generated using the sample .RDL file that you shared earlier.