Free Support Forum - aspose.com

Issue with XLSX format

Hi Team,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

We are getting formatting issue for XLSX format. Take a look into fore color of the text in attached samples.

Please find attached files for your reference.

Note : we are using Aspose.Cells for Reporting Services v1.8.0.26(SSRS2008R2)

Let me know if you need any additional detail.

Thanks,

Aftab Ansari

Hi,

Thanks for your posting and using Aspose.Cells for Reporting Services.

I can notice the issues in your files.

We have logged this issue in our database. We will soon look into your issue and once the issue is resolved or we have some update for you, we will let you know asap.

This issue has been logged as SSRS-40035.

Hi ,

We had found and fixed this issue.

Please download and try the fixed version: Aspose.Cells for Reporting Services V1.8.0.28 (SSRS2008R2).

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /> Hi Team,

Please go through with the first 4 rows in attached Excel and XLSX files. We are getting formatting and displayed value issue in Aspose XLSX format there.

Please find required files as an attachment.

Thanks,

Aftab Ansari

Hi,


Thanks for providing the sample RDL and Excel files.

I can notice the displayed value issue in your attached XLSX (exported via Aspose.Cells for RS) file. I have logged your feedback with your files against your existing issue “SSRS-40035”. I have reopened your issue and we will soon look into your issue.

Thank you.

Hi,

We had fixed the group function.

Please try fixed version: Aspose.Cells for Reporting Services V1.8.0.30(SSRS2008R2).

And let us know if it works fine.


Hi Team,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have tried the Aspose.Cells for Reporting Services V1.8.0.30(SSRS2008R2) DLL but I don’t see any of my issue is resolved that I have mentioned in my previous post.

Let me know if you need any additional information.

Thanks,

Aftab Ansari

Hi,

Thanks for your posting and using Aspose.Cells for Reporting Services.

I have logged your comments against the issue id: SSRS-40035

Could you please provide screenshots that could be helpful in sorting out your issue?

Hi Team,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please refer attached Report2.xls and Report2.xlsx Sheet1 for following issue description:

· On row2, XLS is showing required values whereas XLSX is showing error

· Row4 is coming under the report header in XLS as expected whereas the same is coming under the report body part in XLSX

Note : I am using ACRS2008R2.V1.8.0.30

Thanks,

Aftab Ansari

Hi,


Thanks for the sample files.

We can notice the differences in the XLSX file as you pointed out. We have logged it and we will soon look into your issue.

Thank you.

Hi

  • Row4 is coming under the report header in XLS as expected whereas the same is coming under the report body part in XLSX


We had fixed Freeze header issue.

Please download and try the latest version: Aspose.Cells for Reporting Services V1.8.0.31(SSRS2008R2) and let us know your feedback.

Please copy Aspose.Cells.ReportingServices.dll into following folder :

${SQL Server 2008 R2 Reporting Services}\Reporting Services\ReportServer\bin.

If your problem still occurs, please provide us your RDL file.

Thanks Team.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I see the mentioned issue is fixed. But i have got another issue.

Issue Description:

· In row2, XLS is showing required values whereas XLSX is showing blank.

Please find required file as an attachment.

Thanks,

Aftab Ansari

Hi,

Thanks for your feedback.

We have logged your files and comment in our database against the issue id: SSRS-40035

We will fix the remaining issues and update you asap.

Hi,

Please download and try the fixed version: Aspose.Cells for Reporting ServiceV1.8.0.33(SSRS2008R2) and let us know your feedback.

Please copy Aspose.Cells.ReportingServices.dll into following folder :

${SQL Server 2008 R2 Reporting Services}\Reporting Services\ReportServer\bin.


Hi Team,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have tried the suggested Aspose version and following are the issues I have noticed:

Issue Description:

· See the row-2 values in Sheet1 and Sheet2 in xls and xlsx. In Sheet2, xls has correct value as “Sample Report2” whereas xlsx is showing “Sample Report1”

· Alternate row color is not working XLSX. See Sheet2 table alter row color in xls and xlsx

Please find attached Samples and RDL.

Let me know if you need any additional information.

Thanks,

Aftab Ansari

Hi,

Thanks for your feedback.

I have logged your issues and files, we will look into them and fix the problems and get back to you asap.

Hi,

We had checked your provided files and found the issues.

Please try the fixed version: Aspose.Cells for Reporting Services 1.8.0.34 (SSRS2008R2).

And let us know your feedback.

Please copy Aspose.Cells.ReportingServices.dll into following folder :

${SQL Server 2008 R2 Reporting Services}\Reporting Services\ReportServer\bin.

Hi Team,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please share Aspose DLL of SSRS2008 version too.

Thanks,

Aftab Ansari

Hi,

Thanks for your posting.

We will soon share the required dll with you.

Hi Team,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have pointed 2 issue in my previous post dated 06-15-2012. Out of two issues, one issue has got resolved but still has issue with valid header text data.

Issue Description:

· See the row-2 values in Sheet1 and Sheet2 in xls and xlsx. In Sheet2, xls has correct value as “Sample Report2” whereas xlsx is showing “Sample Report1”

Please find attached Samples and RDL for your reference.

Let me know if you need any additional information.

Thanks,

Aftab Ansari