We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Unnecessary spaces in PDF to HTML conversion

So I’m using the newest release of Aspose PDF 6.9 and I’m finding that unnecessary spaces are being placed at random between words. I have a PDF attached that will show what I’m getting once converted to HTML, I have others I could show as well.

I did see the forum post where someone had the same issue:
<a href="https://forum.aspose.com/t/99258

I don’t see the issue having being resolved. Any help or suggestions would be great, I’ve also attached a screenshot of what I’m seeing from the document uploaded.

Hi Faraji,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for sharing the template PDF file.

I tested your issue with the latest version of Aspose.Pdf for .NET v6.9 and I am unable to reproduce your mentioned issue. I have attached the resultant HTML file for your reference. If you have any other PDF file which you can share with us that can help in reproducing the issue at our end, please share it as it will help us identifying the cause of the problem. Also, please share your system environment details with us i.e. OS, 32 bit or 64 bit processor, .NET Framework etc. This will also help in reproducing the issue soon.

Sorry for the inconvenience,

Okay so the server is Windows Server 2003, 32bit processor, running .NET 3.5. I’m just using a simple conversion and I’m still getting spaces in the HTML. Here’s the code I’m running below:

Aspose.Pdf.Document thePdfDoc = new Aspose.Pdf.Document(“input.pdf”);
thePdfDoc.Save(“converted.html”, Aspose.Pdf.SaveFormat.Html);
StreamReader sr = new StreamReader(attachmentFile);
string mod1 = sr.ReadToEnd();

And attached is the HTML file I’m getting as the output along with the PDF. Do you think this is possibly a licensing issue? I do have an up to date license placed in the /bin folder along with setting the license in the code (e.g. notice the “Objective” line where the word “development” is displayed as “developm ent”)

If you are converting in a different method please show, thanks.

Hi Faraji,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for sharing the details and the source HTML file.

I am able to generate your mentioned issue after an initial test. Your issue has been registered in our issue tracking system with issue id: PDFNEWNET-33716. You will be notified via this forum thread regarding any update against your reported issue. Also, this is not a licensing issue as I have checked it with a valid license.

Sorry for the inconvenience,

The issues you have found earlier (filed as PDFNEWNET-33716) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.