We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Sorting settings lost

Hi,


We have found this sorting issue; whenever we save a workbook containing a sorting setting i.e. “A to Z” the filtering is lost in the generated file.

Note: The sort setting is empty but the arrow is there.

I have attached a small project to demonstrate the issue. I have also attached an input file “input sorted file.xlsx” to use when running the project.

The mini application will generate two files called “generatedFile.xlsx/pdf”. Please have a look at the generated xlsx file and check the sort settings as shown in the screenshot “sort arrow there but there is not sort in the sort window.PNG

Hi,


Thanks for the sample project with a template file.

After an initial test, I am able to observe the issue as you have pointed out. The data sorting setting is lost after re-saving and refreshing the filters in the file. I have logged a ticket with an id “CELLSNET-41729” for your issue. We will look into your issue to figure it out soon.

Thank you.


Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.3.5 and let us know your feedback.

Hi,


Thank you for resolving the issue; I have updated to version 7.4.3.5 and we are no longer experiencing the sorting bug described in this thread.

Hi,

Thanks for your feedback.

It’s good to know your issue
is resolved with the latest fix. If you encounter any other issue,
please feel free to post on forum, we will be glad to help you further.

The issues you have found earlier (filed as CELLSNET-41729) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.